Resolved: SQL Database - Accessibility Issues - Mitigated
Incident Report for BeX
Resolved
SQL Database - Accessibility Issues - Mitigated
Incident

Summary of Impact: Between 04:00 UTC on 01 Feb 2021 and 08:00 on 05 Feb 2021, you were identified as a customer using Azure SQL Database who may have experienced connection errors when accessing your database.    

Preliminary Root Cause: We determined that the issue was caused due to a recent deployment which had a configuration error that affected the underlying backend infrastructure, resulting in connection failures.      

Mitigation: We attempted to mitigate by rolling back the deployment, but found that it was not sufficient due to cached state. As such, we performed a new deployment to fix the configuration to the backend infrastructure to mitigate the issue.    

Next Steps: We sincerely apologize for the impact to affected customers. We will continue to investigate to establish the full root cause and prevent future occurrences. Stay informed about Azure service issues by creating custom service health alerts: https://aka.ms/ash-videos for video tutorials and https://aka.ms/ash-alerts for how-to documentation.



SQL Database
Brazil South
East US
Japan West
North Europe
South Central US
Southeast Asia
UK South
UK West

Posted Feb 05, 2021 - 23:49 CET
Update
We are continuing to investigate this issue.
Posted Feb 05, 2021 - 09:22 CET
Investigating
SQL Database - Accessibility issues - Applying Extended Mitigation
Incident
Starting at 17:00 UTC on 01 Feb 2021, you have been identified as a customer using SQL Database who may experience connection errors when accessing your database.

Current Status: After further investigation, we determined that the mitigation efforts introduced underlying impact. A subset of customers may still encounter some transient connection failures as a result of our ongoing deployment. We are currently rolling out another fix by following safe deployment standards. The next update will be provided in 24 hours, or as events warrant.

SQL Database
Brazil South
East US
Japan West
North Europe
South Central US
Southeast Asia
UK South
UK West

Posted Feb 05, 2021 - 02:54 CET
This incident affected: Bex (Api & Integrations, Bex Backoffice) and Bex.