Bo2 Moving infrastructure.
Incident Report for BeX
Resolved
Moved has been completed
Posted May 14, 2021 - 20:43 CEST
Investigating
Currently Moving infrastructure for bo2
Posted May 14, 2021 - 19:59 CEST
This incident affected: Bex (Bex Backoffice).