Resolved: RCA - SQL Database - Accessibility Issues
Incident Report for BeX
Resolved
RCA - SQL Database - Accessibility Issues
Incident

Summary of impact: Between 04:00 UTC on 01 Feb 2021 and 08:00 on 05 Feb 2021, you were identified as a customer using Azure SQL Database who may have experienced connection errors when accessing your database.

Root cause: During a deployment activity, a set of infrastructure-related configuration changes were deployed out of sequence in a set of clusters, causing Azure SQL Database Service databases on these clusters to be in a misconfigured state; a consequence of this was that attempted connections to those databases would have failed, and some database management operations could fail or halt. In some cases, the impact was delayed until a restart.

Mitigation: The out of sequence deployment was rolled back, and the correct deployment was then necessary to place clusters in a healthy state.

Next steps: We apologize for the impact to affected customers. We are continuously taking steps to improve the Microsoft Azure Platform and our processes to help ensure such incidents do not occur in the future. In this case, this includes (but is not limited to):

  • Reviewing and modifying our deployment control procedures to avoid sequencing mistakes in deployments.
  • Code repairs to component involved to properly refresh the specific property that did not get refreshed on configuration rollback.

Provide Feedback: Please help us improve the Azure customer communications experience by taking our survey: https://aka.ms/AzurePIRSurvey



SQL Database
Brazil South
East US
Japan West
North Europe
South Central US
Southeast Asia
UK South
UK West

Posted Feb 09, 2021 - 11:52 CET
This incident affected: Bex.